Modify

Ticket #790 (closed defect: fixed)

Opened 20 months ago

Last modified 16 months ago

Ability to Change Author of Item

Reported by: anna Owned by:
Priority: major Milestone: 4.6
Component: PlumiVideoProduct Severity: New Ticket
Keywords: Cc:
Who will test this: And

Description (last modified by anna) (diff)

Trying to change the Owner of this video:  https://www.engagemedia.org/Members/anna/videos/test/

I changed it using the Ownership tab to "Andrew L" but it still displays the original Creator (myself) as the owner.

The main use case is that admins sometimes have to upload videos on behalf of other users, and then want to change the username that is associated with the video to the new user.

Attachments

Change History

comment:1 Changed 18 months ago by anna

  • Severity set to New Ticket
  • Description modified (diff)

I just changed the owner of this item to "anna" but the page still says "prove":  http://testing.plumi.org/Members/prove/videos/dont-try-this-8/

Does this page report the Creator, not the Owner?

Should we change all the templates to show the Owner, not the Creator?

comment:2 Changed 18 months ago by anonymous

I really hope we can change this, since i help many videomaker, upload their video to EM website....

comment:3 Changed 18 months ago by anna

markos installed a tool for this - to change the Creator of an item - only for administrators, but its not a good solution. if he can make it work he will write some instructions.

in any case, it will work for adminstrators only.

the view page should list Creator, for many good reasons.

THE PROCESS FOR UPLOADING A VIDEO ON A USER'S BEHALF

  1. upload
  2. change Creator - make this easy to do
  3. change Owner
  4. move it to user's video folder

comment:4 Changed 16 months ago by anna

  • Milestone changed from 4.5 EM and Plumi UI Re-Design to 4.6

Let's review this again in 4.6.

comment:5 Changed 16 months ago by and

This is really quite a critical one as it's something editors do almost every day. It was one of the original top 10. Anyway we can do this quickly in 4.5?

comment:6 Changed 16 months ago by markos

  • Status changed from new to closed
  • Resolution set to ready for testing

I have removed the custom plumi video form from plumi.content, and restored Plone's default one. Now, on tab 'ownership' you can change the creator of a video to an other user, and the other user becomes owner of the video! You have to copy paste the video then to the new user's video folder, and that's all you have to do in order for a video to have a new author changed!

comment:7 Changed 16 months ago by and

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

Rico has tested and confirmed it works.

comment:8 Changed 16 months ago by and

  • Status changed from reopened to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.