Modify

Ticket #590 (closed task: fixed)

Opened 4 years ago

Last modified 3 years ago

Integrate Brazilian Portuguese Plumi 4.0 Translation

Reported by: anna Owned by: mike
Priority: major Milestone: 4.3 Beta1
Component: Translation Severity:
Keywords: Cc: lucianodefazio@…
Who will test this: And

Description (last modified by and) (diff)

Brazilian Portuguese translation .po file attached to this ticket.

On 24/01/11 12:12 AM, Luciano De Fazio wrote:

Hello, And.

I am pleased to be able in send my small contribution for this great open source project.

We are currently planning a migration from a multimedia management portal developed in Plone 2.5 to Plumi, for use by a muncipal council in Brazil.

Once we complete the migration, we will be happy to send you the URL.

Cheers,

Luciano De Fazio

2011/1/22 And

Hi Luciano, that's fantastic. I'm cc'ing this to the main development list so people there can help you with the integration.

Also is it in use anywhere that we can see?

Thanks a bunch, very cool news. And.

Attachments

plumi-brazil-translation.po Download (60.9 KB) - added by anna 4 years ago.

Change History

Changed 4 years ago by anna

comment:1 Changed 4 years ago by anna

  • Description modified (diff)
  • Summary changed from Integrate Brazilian Portuguese Plumi Translation to Integrate Brazilian Portuguese Plumi 4.0 Translation

comment:2 Changed 4 years ago by anna

  • Owner set to dave
  • Milestone changed from 4.2 Beta (Features - Content Sharing Focus) to 4.1 RC 1

comment:3 Changed 4 years ago by anna

please implement this now if possible - let's be responsive to this contributor

comment:4 Changed 4 years ago by dave

  • Status changed from new to closed
  • Resolution set to ready for testing

I have set this up in plumi.locales, committed the .po file.

I am not so familiar with i18n process, following the README in the directory, I ran :

$ i18ndude sync --pot locales/plumi.pot locales/id/LC_MESSAGES/plumi.po locales/es/LC_MESSAGES/plumi.po locales/ms/LC_MESSAGES/plumi.po

locales/pt_BR/LC_MESSAGES/plumi.po

locales/id/LC_MESSAGES/plumi.po: 0 added, 0 removed

locales/es/LC_MESSAGES/plumi.po: 0 added, 0 removed

locales/ms/LC_MESSAGES/plumi.po: 0 added, 0 removed

locales/pt_BR/LC_MESSAGES/plumi.po: 0 added, 0 removed

This seemed odd, so I tried regenerating the plumi.pot

$ i18ndude rebuild-pot --pot locales/plumi.pot --create plumi ../../../plumi.app/ ../../../plumi.content/ ../../../plumi.skin/

which resulted in a lot of errors, namely over the RSS2 areas (tal:content on empty tag etc)

After that, I synced again, this resulted in 6 added, 46 removed as above for each. Reading the actual file it looks ok, however it's probably good that someone familiar with internationalization confirm the process rather than me fuddle around with it at this stage. the '46 removed' has me concerned I have missed something.

Last edited 4 years ago by dave (previous) (diff)

comment:5 Changed 4 years ago by anna

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

hmm, i tried to test this, but it didn't seem to work. activating Indonesian didn't seem to work either...

 http://testing.plumi.org:16080/Plone?set_language=id  http://testing.plumi.org:16080/Plone?set_language=pt-br

was this meant to be available on your testing site dave?

comment:6 Changed 3 years ago by dave

Just an update.

$ cd plumi.locales/plumi/locales

$ rm locales/plumi.pot

$ i18ndude rebuild-pot --pot locales/plumi.pot --create plumi ../../../plumi.app/ ../../../plumi.content/ ../../../plumi.skin/

This creates a whole string of warnings, I am not sure if they have to be fixed to resolve, or actually cause any issue or just warnings.

note: one is mentioned here : http://plumi.org/ticket/221

I used this workaround to test, but there are also outstanding ones with regard i18n tags in specifically the RSS feeds for news and events and callouts that require a custom tag, as the default is already defined elsewhere differently.

$ i18ndude sync --pot locales/plumi.pot locales/id/LC_MESSAGES/plumi.po locales/es/LC_MESSAGES/plumi.po locales/ms/LC_MESSAGES/plumi.po locales/pt_BR/LC_MESSAGES/plumi.po

Doing this on my  http://localhost:8080/Plone?set_language=id or  http://localhost:8080/Plone?set_language=pt-br I get no translation.

However :

 http://testing.plumi.org:16080/Plone/Members/test/videos/test-video/?set_language=id

 http://testing.plumi.org:16080/Plone/Members/test/videos/test-video/?set_language=pt-br

work.

I presume, but not familiar with translations, that I should fix all the issues with translation strings all through the code to fix this. I will go ahead with this, but noting where I am at in this ticket in case someone familiar with i18n can point me at the issue/process I am missing.

It appears that translations are half working, but only the plumi translations, not the plone ones.

On startup on my local installation I get warnings about the compiling:

2011-01-31T17:32:41 WARNING zope.i18n Error while compiling /opt/plumi/trunk/src/plumi.locales/plumi/locales/locales/id/LC_MESSAGES/plumi.po
------
2011-01-31T17:32:41 WARNING zope.i18n Error while compiling /opt/plumi/trunk/src/plumi.locales/plumi/locales/locales/es/LC_MESSAGES/plumi.po
------
2011-01-31T17:32:41 WARNING zope.i18n Error while compiling /opt/plumi/trunk/src/plumi.locales/plumi/locales/locales/ms/LC_MESSAGES/plumi.po
------
2011-01-31T17:32:41 WARNING zope.i18n Error while compiling /opt/plumi/trunk/src/plumi.locales/plumi/locales/locales/pt_BR/LC_MESSAGES/plumi.po

comment:7 Changed 3 years ago by dave

  • Status changed from reopened to new
  • Owner changed from dave to mike

comment:8 Changed 3 years ago by mike

  • Status changed from new to closed
  • Resolution set to ready for testing

check it out on staging.engagemedia.org :)

comment:9 Changed 3 years ago by and

  • Status changed from closed to reopened
  • Resolution ready for testing deleted
  • Description modified (diff)

Awesome. Couple of things

  • the flags are pushed across to the right of the page pushing the whole site out (firefox and chrome I have tested, may be others)
  • you lose a lot of the pages in the left nav. when you choose pt-br. even if there are no translations the default should stay there
  • looks like there is still a few things missing, but there is a lot in there, def. enough to ship with.

comment:10 Changed 3 years ago by dave

Hiya Mike, out of interest, what was missing in the process? Would it be a good idea to update the README.txt?

And, some of the things I have added in templates do not have i18n tags, being able to test the process for updating the files would give me the ability to add some of this for translation

comment:11 Changed 3 years ago by and

  • Priority changed from major to blocker

This is almost there so make it a blocker for rc1 release.

comment:12 Changed 3 years ago by mike

  • Status changed from reopened to closed
  • Resolution set to ready for testing

I've fixed the flags issue as far as I can tell (shift+refresh on staging). The pages that we miss in the left nav are because of this linguaplone bug:  http://plone.org/products/linguaplone/issues/262

dave, as far as I can tell, the README instructions still apply. But these are to create the .pot file and synchronize the .po files to the new pot. There are a couple of issues with linguaplone that you may have hit (like the tabs one described in the other ticket). Other than that, there was an issue with em.skin that prevented language changing that is now resolved.

comment:13 Changed 3 years ago by and

  • Cc lucianodefazio@… added

OK, so we make another ticket to follow that bug? Any ideas when it might be fixed? Can you make the ticket? You'll write it better than me ;)

Luciano does the translation look ok to you?

comment:14 Changed 3 years ago by mike

There is already that ticket on the linguaplone bug tracker which is in confirmed status. Usually linguaplone bugs get fixed soon. We should wait a few weeks and check the bug's progress.

comment:15 Changed 3 years ago by and

  • Milestone changed from 4.1 RC 1 & EM Staging Update to 4.2 Beta (Features - Content Sharing Focus)

OK, I'll push this to 4.2 as something to check later on and remind us.

comment:16 Changed 3 years ago by and

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

comment:17 Changed 3 years ago by and

  • Priority changed from blocker to major

comment:18 Changed 3 years ago by mike

  • Status changed from reopened to closed
  • Resolution set to fixed

Brazilian translations are included on plumi 4.1 so I'm closing this and opening a new one about the tabs issue on 4.3

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.