Modify

Ticket #482 (closed task: fixed)

Opened 3 years ago

Last modified 3 years ago

First look at Plone 4 adaptation

Reported by: david Owned by:
Priority: minor Milestone: 4.0 Beta
Component: AuthorProfile Severity:
Keywords: plone4 tips Cc:
Who will test this: And

Description

After a very quick look, I have found that these two products are no longer available for Plone 4:

  • Products.ATVocabularyManager
  • Products.ATCountryWidget

It is possible to add these products to the buildout and suppress the dependency errors but they both declare interfaces in a Zope 2 way which is now removed from Plone4.

There is information on how these interfaces should be declared in:

 http://plone.org/documentation/manual/upgrade-guide/version/upgrading-plone-3-x-to-4.0/updating-add-on-products-for-plone-4.0/no-more-zope-2-interfaces

The optimal solution would be to discard these two products and redesign their functionality on the product.

Porting my old products to Plone 4 lately has been quite pain free actually and there is really good "all you need" documentation here:

 http://plone.org/documentation/manual/upgrade-guide/version/upgrading-plone-3-x-to-4.0

Attachments

Change History

comment:1 Changed 3 years ago by and

  • Milestone set to 4.0 Beta

comment:2 Changed 3 years ago by dimo

Fixed in trunk.

Plumi no longer depends on ATCountryWidget. Instead we use a standard selection widget and the country list is managed by ATVocabularyManager which has released an alpha recently that works with Plone 4.

comment:3 Changed 3 years ago by dimo

  • Status changed from new to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.