Modify

Ticket #47 (closed enhancement: fixed)

Opened 7 years ago

Last modified 3 years ago

16:9 Flow player support

Reported by: and Owned by:
Priority: blocker Milestone: 4.3 Beta1
Component: Transcoding Severity:
Keywords: Cc:
Who will test this: And

Description (last modified by anna) (diff)

Currently 16:9 videos are letter-boxed to 4:3 in the Flowplayer.

Investigate possibility of player conforming to native aspect ratio of video file.

Attachments

fullscreen-display-prob-tenfourfox.jpg Download (67.2 KB) - added by anna 3 years ago.
Fullscreen video display error FourTenFox? Mac OS 10.4.11

Change History

comment:1 Changed 7 years ago by anna

  • Type changed from task to enhancement
  • Description modified (diff)
  • Summary changed from 16x9 videos squished to 4x3 by IndyTube to 16:9 Widescreen Video Support in Indytube / Flowplayer

comment:2 Changed 5 years ago by andycat

  • Milestone changed from 0.5 - to 0.4 -

comment:3 Changed 5 years ago by vik

  • Milestone changed from 3.1 to 3.2

comment:4 Changed 4 years ago by anna

  • Who will test this set to And
  • Milestone changed from 4.3 to 4.1 Beta

comment:5 Changed 4 years ago by and

  • Owner andycat deleted

comment:6 Changed 4 years ago by anna

  • Description modified (diff)
  • Summary changed from 16:9 Widescreen Video Support in Indytube / Flowplayer to Investigate 16:9 Widescreen Video Support for Site Redesign

comment:7 Changed 4 years ago by anna

  • Milestone changed from 4.1 Beta 1 (New Features and Fixes) to 4.2 Beta (Features and Refactoring)

It doesn't sound like this has been looked into much for this milestone, so will bump it to the next in the interest of getting 4.1 out soon.

comment:8 Changed 4 years ago by anna

  • Milestone changed from 4.2 Beta (Features - Content Sharing Focus) to 4.3 Beta (Re-Design of EM.org & Plumi)

comment:9 Changed 4 years ago by and

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone changed from 4.3 Beta (Re-Design of EM.org & Plumi) to 4.2 Beta (Features - Content Sharing Focus)

There's been a strong request for this so bumping to 4.2.

What do you folks think?

comment:10 Changed 4 years ago by and

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not sure why that closed. Reopening.

comment:11 Changed 4 years ago by and

Dimo/Mike? - how difficult is this?

comment:12 Changed 3 years ago by and

  • Priority changed from major to blocker

Note - it may be that is the issue is not that the transcoder doesn't correctly transcode the video, but just that the player stretches it.

Thumbnails for example from 16:9 videos come out 16:9 as does the ogg transcode. I haven't fully investigated this but this is my suspicion.

This is a 16:19 you can use for further investigation.  http://www.engagemedia.org/Members/andrew/videos/RW-GSCFF.m4v/view

comment:13 Changed 3 years ago by and

  • Summary changed from Investigate 16:9 Widescreen Video Support for Site Redesign to 16:9 Flow player support

comment:14 Changed 3 years ago by and

  • Milestone changed from 4.3 Beta1 to 4.2.3

comment:15 Changed 3 years ago by mike

  • Status changed from reopened to closed
  • Resolution set to ready for testing

16:9 is working now. You can test it on  http://testing.plumi.org/Members/clopy/videos/test-16-9/view

The transcoder now keeps the aspect ratio of the original file, and flowplayer does not stretch the video any more. I've kept the 4:3 aspect ratio that we had on flowplayer on the video view.

comment:16 Changed 3 years ago by and

I can't load the test site to test this.

comment:17 Changed 3 years ago by markos

Hi And,

testing.plumi.org is working here. Check on /etc/hosts if you have a similar entry

127.0.0.1 testing.plumi.org

which points testing.plumi.org to localhost, then it has to be removed. That entry is used if you install Plumi on your system...

Hope this helps

comment:18 Changed 3 years ago by and

Is it possible to do this without adding it to /etc/hosts and change something on the other end? I might need to show other people who aren't as geeky ;)

comment:19 Changed 3 years ago by and

I managed to load that page but no video appeared in the player.

Mike, the player should shift to a 16:9 size when it has a 16:9 video. I think it's better that 16:9 is the default size as the majority of new videos these days are 16:9

comment:20 Changed 3 years ago by dimo

  • Milestone changed from 4.2.3 to 4.3 Beta1

comment:21 Changed 3 years ago by anna

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

Some testing notes.

  1. The video player aspect ratio is 16:9 for all videos. Is it possible for the player to auto-detect the aspect ratio and display the player (or a different version of the player) in the correct aspect ratio? I realise that YouTube? etc. just have the player in 16:9 with sideways letterboxing for 4:3 videos, as we have here. But worth asking - is this possible?
  1. The video player seems to auto buffer / load the video on page load. This should probably be changed. With YT, the video does not load until the tab or window is activated. This is one choice we could make, if this is possible to implement. Or, perhaps we could opt for not loading the video until the play button is clicked (which I think is what we used to have).

comment:22 Changed 3 years ago by anna

Have been thinking about backwards-compatibility with Plumi sites with existing video archives encoded as 4:3.

If we re-transcode all videos to 16:9, and change the player to display 16:9, all videos on the Plumi site itself will display reasonably.

However - videos that have been already embedded on other sites - if these link to the re-transcoded videos, the 16:9 video will be displayed in a 4:3 player.

Would it then be the best option to link to new files in the new player, leaving a copy of 4:3 encoded videos on the server, so these embedded videos still display properly...?

comment:23 Changed 3 years ago by anna

Also checking - if video files are re-transcoded - will auto-generated thumbs also be re-transcoded to 16:9?

We probably need to check around the site to make sure these images are displayed in the correct aspect ratio.

For example, in the "Other videos by this author" section on the video/view page, as well as in video listings, these images are displayed as 4:3.

This should ideally be corrected before releasing the final version of 4.3 to make sure this change doesn't introduce ugly design problems.

comment:24 Changed 3 years ago by anna

The player on the front page is still displaying in 4:3 ratio.  http://testing.plumi.org/

Also, the thumbnail is not displayed correctly within the player on page load. You can see the thumb from the currently featured video is close to square, sitting within the player, not quite stretched to the edges. Possibly a couple of things to fix there to make it display nicely.

comment:25 Changed 3 years ago by anna

Another issue I found with the player - though I am testing this on a not-very-common platform/browser combination.

When I click fullscreen, the player pops up to fill the browser window. However the video only plays back in the corner of the frame, not in fullscreen (black window elsewhere - see screenshot).

Changed 3 years ago by anna

Fullscreen video display error FourTenFox? Mac OS 10.4.11

comment:26 Changed 3 years ago by anna

(Using Firefox fork "FourTenFox?" enabling later FF releases to run on PPC Macs - using Mac OS 10.4.11)

comment:27 Changed 3 years ago by anna

Also encounter this fullscreen video problem on Safari 5.0.6 / Mac OS 10.4.11

comment:28 Changed 3 years ago by mike

Hi Anna, I'll start answering comment by comment:

21: 1) It is possible, but it's better to have a consistent player size instead of changing it depending on the video. There are more aspects than 16:9 and 4:3 and things could break or seem ugly if the player size is changing. I think this is why youtube also has a standard player size.

2) I think the player only loads a few seconds for instant playback, but the video on testing is a bit small to test. I'll check with a bigger one.

22: Keeping both video sizes would increase our disk space needs a lot I think. What we can do though is change the video size inside the iframe so that if the video is 4:3 it'll just scale it down and not distort it.

23: Thumbs will be regenerated, but those images sizes were fixed sized. We'll update the code to make them 16:9 too.

24: Video should be 16:9 now.

25: I'm not seeing this on my setup. If we can reproduce it on a more common setup we'll have to file a bug with the mediaelementsjs people. But it could be related to an old video driver issue with modern browsers.

comment:29 Changed 3 years ago by dimo

  • Status changed from reopened to closed
  • Resolution set to ready for testing

The fullscreen button issue is caused by a conflict between UniversalSubtitles? and MediaelEmentJS. We added some code that mitigates the problem. Try it out on testing.plumi.org

Unless there are any important problems remaining I think we should close this ticket. Resizing the other videos thumbnails to 16:9 has wider implications for all thumbnails in the site and I'm not sure it's a good idea anyway. Why should small thumbnail images maintain the aspect ratio of the original video? This wouldn't look well in a listing of videos with different aspect rations.

comment:30 Changed 3 years ago by anna

The fullscreen button issue seems to be resolved.

We can leave the issue of the thumbnail aspect ratio until the re-design.

comment:31 Changed 3 years ago by anna

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

comment:32 Changed 3 years ago by anna

  • Status changed from reopened to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.