Modify

Ticket #443 (closed task: fixed)

Opened 4 years ago

Last modified 4 years ago

Videos frequently not picked up by Transcode.Daemon for transcoding

Reported by: and Owned by:
Priority: blocker Milestone: 3.1.1
Component: Transcoding Severity:
Keywords: Cc:
Who will test this: Grant

Description

We are finding on EngageMedia.org that TD is frequently not picking up new videos and transcoding them. There _may_ be a link to whether they are uploaded via ftp. Generally they will transcode if you click "retranscode" but obviously it is much better if it is done so automatically, both for the admins and for the users.

I don't have any specific examples on EM right now but have a look through the public draft videos. If I see a non-transcoded video for the sake of the user and the site we need to transcode it immediately.

Attachments

Change History

comment:1 Changed 4 years ago by and

  • Milestone changed from 3.2 to 3.1.1

comment:2 Changed 4 years ago by mike

  • Status changed from new to closed
  • Resolution set to ready for testing

We've made some changes to catch some of these cases. I've updated testing. While testing stuff, take a look to check if the problem is still there when uploading new videos.

comment:3 Changed 4 years ago by and

  • Who will test this changed from And to Grant

comment:4 Changed 4 years ago by grant

May not be able to mark this as closed until after we deploy 3.1.1 to production on em.org as ftp upload is going to production, not staging. We can test uploading & transcoding videos during acceptance testing but the FTP angle will have to wait.

comment:5 Changed 4 years ago by and

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

I uploaded 2 videos to staging.em. 1+ hour later they don't seem to been picked up for transcoding. Unless TD is very busy this would suggest to me there are still some issues.

Re-opening.

comment:7 Changed 4 years ago by grant

Here's another one - uploaded it a while back and still no transcoding and no sign of ffmpeg running (looking via htop).

 http://staging.engagemedia.org/Members/grant/videos/will-that-progress-bar-show/

comment:8 Changed 4 years ago by dimo

  • Status changed from reopened to closed
  • Resolution set to ready for testing

ok, problem found and fixed!

comment:9 Changed 4 years ago by grant

Uploaded a video and it transcoded successfully. Will upload a few more later this arvo but so far it looks good :)

comment:10 Changed 4 years ago by grant

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

Uploaded a few more videos and they've all transcoded correctly. Looks like the transcoder is working.

Only thing left to test is the transcoding when a video is uploaded via FTP. Have to wait until we deploy into production for that.

Will mark this as completed and ensure we test the FTP transcoding during production acceptance testing.

comment:11 Changed 4 years ago by grant

  • Status changed from reopened to closed
  • Resolution set to fixed

All done - closing it out

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.