Modify

Ticket #372 (closed task: invalid)

Opened 4 years ago

Last modified 3 years ago

Apache buildout leaving code cruft in /tmp

Reported by: jimby Owned by:
Priority: major Milestone: 4.9
Component: Buildout Severity:
Keywords: filesystem full /tmp buildout apache Cc:
Who will test this: And

Description

The apache buildout leaves the working code in /tmp :

drwx------   3 root  wheel     512 Mar 16 15:42 tmp202X0obuildout-apachebuild
drwx------   3 root  wheel     512 Mar 17 11:23 tmp4cck05buildout-apachebuild
drwx------   3 root  wheel     512 Mar 16 21:43 tmpICPBE1buildout-apachebuild
drwx------   3 root  wheel     512 Mar 14 16:22 tmpcorx0Cbuildout-apachebuild
drwx------   3 root  wheel     512 Mar 14 22:43 tmpfQv0rNbuildout-apachebuild
drwx------   3 root  wheel     512 Mar 14 18:43 tmpr8zGH8buildout-apachebuild
drwx------   3 root  wheel     512 Mar 17 08:51 tmpsHTsjZbuildout-apachebuild
drwx------   3 root  wheel     512 Mar 15 09:35 tmptargAxbuildout-apachebuild
.....

Multiple buildouts can fill /tmp leading to problems with other programs that use /tmp, including Plone (which uses it for product installations).

Recommend action is to remove the /tmp/tmpxxxxxbuildout-apachebuild at the end of the install, if the build was succeessful.

Or, at the very least, informing the user so they can remove it themselves.

Attachments

Change History

comment:1 Changed 4 years ago by grant

  • Owner andycat deleted
  • Milestone changed from 3.0-RC1 to 3.1

comment:2 Changed 4 years ago by grant

  • Milestone changed from 3.1 to 3.0-RC2

comment:3 Changed 4 years ago by mike

I can confirm this, though this is an apache buildout issue. We could provide one of the proposed solutions, although I'm worried that when it is properly fixed on the apache recipe, we'll end up with an unneeded dirty hack or warning.

I'm leaning towards leaving it as it is until it is properly fixed and filing a bug report in the right place, since the /tmp folder is cleaned up periodically on most systems and the files left are only around 50MB, but I 'ld like to hear more opinions on this.

comment:4 Changed 4 years ago by and

  • Milestone changed from 3.0-RC2 to 3.1

I'm happy to push it down given we're trying to get rc2 by today, it can go into 3.1 but with a high priority. I'm going to move it.

comment:5 Changed 4 years ago by grant

  • Who will test this set to And
  • Milestone changed from 3.1 to 4.1

Dimo indicated this was not an issue for us but the apache recipe and should be deferred to later (did I recall that right, Dimo? :)

comment:6 Changed 3 years ago by and

  • Milestone changed from 4.3 to 4.4

comment:7 Changed 3 years ago by anna

  • Status changed from new to closed
  • Resolution set to invalid

is this still an issue? assuming it is now invalid, but if is is still relevant please re-open.

comment:8 Changed 3 years ago by and

  • Milestone changed from 4.6 Beta (New Features and Fixes) to 4.7 Beta

Milestone 4.6 Beta (New Features and Fixes) deleted

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.