Modify

Ticket #289 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Naming scheme of videos has changed

Reported by: vik Owned by:
Priority: major Milestone: 3.0-Migration
Component: PlumiVideoProduct Severity:
Keywords: Cc:
Who will test this:

Description (last modified by vik) (diff)

I plumi 0.2.3, the URL scheme of a video is:

 http://site/Members/member/videos/video_filename.mp4 - downloads original

 http://site/Members/member/videos/video_filename.mp4/view - views in the embedded player

In plumi 3, the scheme is:

 http://site/Members/member/videos/VideoTitle - views in embedded player

 http://site/Members/member/videos/VideoTitle/download/video_filename.mp4 - downloads original

The difference is in the new system, the URL is calculated from the title, which in the old system, from the filename. For migrated videos the following will occur:

 http://site/Members/member/videos/video_filename.mp4 - views in the embedded player

 http://site/Members/member/videos/video_filename.mp4/view - views in the embedded player

 http://site/Members/member/videos/video_filename.mp4/download/video_filename.mp4

This may break some links (namely to the original files), and cause other wierdness/inconsistencies if the old and new systems are combined

Attachments

Change History

comment:1 Changed 5 years ago by vik

  • Description modified (diff)

comment:2 Changed 5 years ago by dimo

  • Milestone changed from 3.0-RC1 to 3.0-Migration

comment:3 Changed 5 years ago by and

  • Status changed from new to closed
  • Resolution set to fixed

Discussed with Dimo. We're happy that the problem is solved enough to not cause too much inconvenience. The only limitation is that it requires someone to click twice to get to the video if they are using the old direct download link.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.