Modify

Ticket #274 (closed task: fixed)

Opened 4 years ago

Last modified 4 years ago

Upgrade buildout to Plone 3.3.x

Reported by: vik Owned by: vik
Priority: blocker Milestone: 3.0-beta2
Component: Buildout Severity:
Keywords: Cc:
Who will test this:

Description (last modified by and) (diff)

Change to use the latest stable version of Plone, 3.3.x, and upgrade picked versions to a stable set for this distro.

Attachments

Change History

comment:1 Changed 4 years ago by and

  • Priority changed from major to blocker

comment:2 Changed 4 years ago by and

  • Milestone changed from 3.0-beta to 3.0-beta2

comment:3 Changed 4 years ago by and

Hedley got this working at the sprint, and is planning on updating it more tomorrow - note from him


Basic working buildout is called buildout_plone331.cfg.

We still need better seperation of .cfg files since developer eggs are currently being pulled into the basic buildout. I'll create base.cfg, buildout.cfg, dev.cfg and leave zeo.cfg as an exercise :)

Then we can do ./bin/instance -c dev.cfg

comment:4 Changed 4 years ago by marton.schimcsig@…

Checked out the latest plumi from  https://svn.engagemedia.org/project/plumi-buildout-plone3/trunk/ , ran buildout_plone331.cfg and got the error:

While:

Installing. Getting section zeo. Initializing part zeo.

Error: There is a version conflict. We already have: zope.component 3.7.1 but five.localsitemanager 1.1 requires 'zope.component<3.6dev'. * PICKED VERSIONS [versions] zope.browser = 1.2 zope.traversing = 3.8.0

#Required by: #zdaemon 2.0.4 #ZODB3 3.9.3 ZConfig = 2.7.1

#Required by: #ZODB3 3.9.3 zdaemon = 2.0.4

#Required by: #plone.locking 1.2.0 #plone.portlets 1.2 zope.annotation = 3.5.0

#Required by: #plone.portlets 1.2 #Products.ATContentTypes 1.3.3 zope.app.container = 3.8.0

#Required by: #plone.browserlayer 1.0.1 zope.app.publication = 3.9.0

#Required by: #zope.app.publication 3.9.0 #zope.publisher 3.10.0 zope.authentication = 3.7.0

#Required by: #Products.LinguaPlone? 3.0b8 zope.component = 3.7.1

#Required by: #plone.portlets 1.2 #plone.app.viewletmanager 1.2.2 zope.contentprovider = 3.5.0

#Required by: #zope.app.publication 3.9.0 zope.error = 3.7.0

#Required by: #zope.component 3.7.1 #ZODB3 3.9.3 zope.event = 3.4.1

#Required by: #Products.kupu 1.4.15 #zope.app.container 3.8.0 #zope.traversing 3.8.0 #zope.app.publication 3.9.0 #zope.publisher 3.10.0 zope.i18n = 3.7.1

#Required by: #plone.browserlayer 1.0.1 #zope.proxy 3.5.0 #zope.component 3.7.1 #ZODB3 3.9.3 zope.interface = 3.5.2

#Required by: #zope.annotation 3.5.0 #zope.contentprovider 3.5.0 #zope.viewlet 3.6.1 #zope.app.container 3.8.0 #zope.app.publication 3.9.0 #zope.publisher 3.10.0 zope.location = 3.7.0

#Required by: #plone.portlets 1.2 #zope.app.container 3.8.0 zope.publisher = 3.10.0

#Required by: #z3c.autoinclude 0.3.1 #plone.portlet.static 1.2rc1 #plone.app.workflow 1.2 #plone.locking 1.2.0 #plone.portlets 1.2 #Products.kupu 1.4.15 #zope.app.container 3.8.0 zope.schema = 3.5.4

#Required by: #Products.CMFPlacefulWorkflow 1.4.2 #ZODB3 3.9.3 zope.testing = 3.8.3

#Required by: #plone.locking 1.2.0 #plone.app.viewletmanager 1.2.2 zope.viewlet = 3.6.1

comment:5 Changed 4 years ago by and

  • Owner changed from andycat to vik
  • Description modified (diff)
  • Summary changed from Upgrade buildout to Plone 3.3.1 to Upgrade buildout to Plone 3.3.x

comment:6 Changed 4 years ago by vik

  • Status changed from new to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.