Modify

Ticket #240 (closed enhancement: fixed)

Opened 5 years ago

Last modified 5 years ago

Plumi 0.3 alpha release to fix

Reported by: anonymous Owned by: andycat
Priority: major Milestone: 0.3alpha - Plumi to Plone 3
Component: PlumiVideoProduct Severity:
Keywords: Cc: yurj@…
Who will test this:

Description

Hi!

I've downloaded and installed this version of Plumi:

http://plumi.org/browser/plumi-buildout-plone3/tags/plumi-0.3-alpha1

To fix:

  • buildout works, but miss an "eggs" directory. Adding it, buildout finishes without errors.

I've enabled all the Plumi related products in the control panel, including LinguaPlone?

  • The skin for users still point to createObject=ATEngageVideo instead of PlumiVideo?.
  • PlumiVideo? is not global addable
  • Users area are not added by default (Plone 3 defaul behaviour)
  • Switching the view of PlumiVideo? to video_view, it returns an error:
    Request URL  	http://localhost:9080/plumi_prova/Members/admin/videos/fdfs/video_view
    Exception Type 	TraversalError
    Exception Value 	(<Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xe156d0c>, 'genres')
    
  • I've tested it with a 212 MB video and blob support rocks :) Great work, really! I can upload in few seconds and download as fast as the net is.

Maybe it is just me wrong on install, I've just enables the products in the control panel

Attachments

Change History

comment:1 Changed 5 years ago by andycat

hey

Awesome!

Can you try again on a fresh install.

PlumiVideo? is by design not globally addable, but can go inside the Plumi Video folder.

A new user should have the ability to add a PlumiVideo? to their own PlumiVideoFolder?.

The 'Plumi Application Setup' is the only product in the QI that needs installing - this should enable members folders btw - you can test this by creating a new non-admin user and login-ing - you shld see comments in the zope log, plus you should see news/events/videos/callouts in your home folder.

Ive correct the publish template yesterday, so it has links to PlumiVideo?, not ATEngageVideo anymore.

The eggs directory is a wierd one - i have a buildout conf that puts eggs in ~/.buildout/eggs, but if you dont, its trys locally I guess - however, AFAIK, we cant have eggs in SVN, since we dont want that directory and its eggs under version control.

let me know,

comment:2 Changed 5 years ago by yurj

I'm testing again.

  • ok to install only the plumi application setup, nice :)
  • users still can't log in when I add them cause I get this:
    *  Module None, line 3, in notifyMemberAreaCreated
      <FSPythonScript at /prova-plumi/notifyMemberAreaCreated used for /prova-plumi/Members/prova>
      Line 3
    * Module plumi.app.member_area, line 43, in notifyMemberAreaCreated
    * Module OFS.CopySupport, line 195, in manage_pasteObjects
    * Module Products.CMFCore.PortalFolder, line 443, in _verifyObjectPaste

ValueError: Disallowed subobject type: Plumi Callout Folder

Idem for Plumi Video Folder, seems cannot be created on user folder.

Adding to global addables, fix it and users can log in and put content.

video_view still does not work:

  Module zope.tales.tales, line 696, in evaluate
   - URL: index
   - Line 30, Column 1
   - Expression: <PathExpr standard:'view/genres'>
   - Names:
      {'container': <PlumiVideo at /prova-plumi/Members/prova/videos/prova-video>,
       'context': <PlumiVideo at /prova-plumi/Members/prova/videos/prova-video>,
       'default': <object object at 0xb7bac528>,
       'here': <PlumiVideo at /prova-plumi/Members/prova/videos/prova-video>,
       'loop': {},
       'nothing': None,
       'options': {'args': (<Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xeeaebcc>,)},
       'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0xef00d2c>,
       'request': <HTTPRequest, URL=http://localhost:9080/prova-plumi/Members/prova/videos/prova-video/video_view>,
       'root': <Application at >,
       'template': <ImplicitAcquirerWrapper object at 0xef49d4c>,
       'traverse_subpath': [],
       'user': <PloneUser 'prova'>,
       'view': <Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xeeaebcc>,
       'views': <zope.app.pagetemplate.viewpagetemplatefile.ViewMapper object at 0xeeae4cc>}
  Module zope.tales.expressions, line 217, in __call__
  Module Products.PageTemplates.Expressions, line 155, in _eval
  Module zope.tales.expressions, line 124, in _eval
  Module Products.PageTemplates.Expressions, line 105, in trustedBoboAwareZopeTraverse
  Module zope.traversing.adapters, line 164, in traversePathElement
   - __traceback_info__: (<Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xeeaebcc>, 'genres')
  Module zope.traversing.adapters, line 52, in traverse
   - __traceback_info__: (<Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xeeaebcc>, 'genres', [])
TraversalError: (<Products.Five.metaclass.SimpleViewClass from /home/yurj/progetti/plone/test7/plumi/plumi-0.3-alpha1/src/plumi.skin/plumi/skin/browser/templates/plumi_video_view.pt object at 0xeeaebcc>, 'genres')

comment:3 Changed 5 years ago by andycat

Hi

The fix for the users is in SVN . you need to re-run the buildout, to get the latest from SVN- or go into src/ and do svn update in plumi.{content|skin|app}

Yeah - the video_view is still broken :(

comment:4 Changed 5 years ago by andycat

  • Owner set to andycat

comment:5 Changed 5 years ago by andycat

  • Status changed from new to closed
  • Resolution set to fixed

try alpha2 :)

Video view is working now.

comment:6 Changed 5 years ago by and

OK, can you point me to a test site so I can have a look?

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.