Modify

Ticket #222 (new task)

Opened 5 years ago

Last modified 3 years ago

Remove Action - Renaming Video Item - When in Pending/Published State

Reported by: and Owned by:
Priority: major Milestone: 4.8
Component: ATEngageVideo Severity:
Keywords: Cc:
Who will test this: Unknown

Description (last modified by anna) (diff)

Attempting to change the name of a video item that is published or pending I get this:

New Short Name Short name is the part that shows up in the URL of the item. New Title You are not allowed to modify the title of this item.

The user does not have permission but it comes up as an option and as such is confusing.

We should take this option out.

In the EM skin we should look at more complex methods of giving the Member an "edit" button which then retracts the video automatically so they can edit it / rename it.

Attachments

Screen shot 2009-11-01 at 1.04.27 PM.png Download (35.0 KB) - added by barry 4 years ago.

Change History

comment:1 Changed 5 years ago by vik

  • Cc and@…, andycat@… added

I don't completely understand this bug; can someone elaborate?

comment:2 Changed 5 years ago by and

  • Milestone changed from 3.1 to 3.2

comment:3 Changed 4 years ago by barry

when you go to  http://website.org/Members/USERNAME/videos/folder_contents

you have an option to select a video and rename it. on the current install on engage a new user (or a non-escalated user) can't rename their own files.

Renaming seems to work in plumi3.

Changed 4 years ago by barry

comment:4 Changed 3 years ago by and

  • Owner andycat deleted
  • Who will test this set to And

comment:5 Changed 3 years ago by and

  • Cc and@…, andycat@… removed
  • Who will test this changed from And to Unknown

comment:6 Changed 3 years ago by and

  • Milestone changed from 4.3 to 4.1 Beta

comment:7 Changed 3 years ago by and

  • Summary changed from New user does not have permissions to rename video item to Member UI/workflow enhancements for renaming video object
  • Milestone changed from 4.1 Beta to 4.2 Beta

comment:8 Changed 3 years ago by anna

  • Description modified (diff)
  • Summary changed from Member UI/workflow enhancements for renaming video object to Remove Action - Renaming Video Item - When in Pending/Published State

comment:9 Changed 3 years ago by and

  • Milestone changed from 4.2 Beta to 4.1 Beta 2

comment:10 Changed 3 years ago by anna

  • Owner set to dave

comment:11 Changed 3 years ago by anna

  • Status changed from new to closed
  • Resolution set to duplicate

From conversations with Dave, this is an EM-specific task and needs to be moved to the Redmine tracker, have created a ticket here:  http://redmine.engagemedia.org/issues/1699

That ticket concerns confusing user-interface experiences when a member is looking at the folder_view of, for example, their Videos folder, and they try to Rename a video that is pending or published.

From Dave: the action (permission) is already removed on the object itself, however the folder view may contain other videos, so the option to rename one of them has to stay to allow other objects to be renamed or copied etc, and the system can only tell you have chosen an object you do not have permission to rename, once you do the action on it

Given this, my suggestion is to remove this view, and remove that "Contents" tab from the Member folder, and its children, for ordinary Members of the EM.org site. We want to redesign the UI with a "less is more" approach in any case, and this kind of functionality is very "Plone" and a bit "intranet" and probably more control over content than an ordinary user really needs.

comment:12 Changed 3 years ago by anna

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Hmm, ok, after a bit of confusion, I'm re-opening this on Plumi trac, rather than on EM.

This can be done in Plumi, with a way to disable it as an option inside the configlet for Plumi Settings.

From Dave.."I have a fix for this, entered into Plumi davo branch ...

think this was done in plumi.app [24/01/11 4:39:05 PM] Dave Fregon: r229288 | axxs | 2010-12-22 10:46:52 +1000 (Wed, 22 Dec 2010) | 2 lines

Removed the ability for owners to change the view on folders, as per ticket #255 . This still enables Managers and editors to change it if needed."

comment:13 Changed 3 years ago by anna

  • Milestone changed from 4.2 Beta (Features and Refactoring) to 4.1 Beta 1 (New Features and Fixes)

comment:14 Changed 3 years ago by anna

this has been done, except for the ability to reverse this configuration in configlet.

let's just put this in Plumi for now, and it can be put into configlet later.

that means taking out whatever code there is regarding the configlet for now, leaving the change itself.

comment:15 Changed 3 years ago by dave

  • Status changed from reopened to closed
  • Resolution set to ready for testing

comment:16 Changed 3 years ago by anna

  • Status changed from closed to reopened
  • Resolution ready for testing deleted

tested this here:  http://testing.plumi.org:16080/Plone/Members/reviewer/videos/test-for-222/

i can rename the video, and it renames successfully in pending state, as a Reviewer. i can give it a new short name, and a new title

in published state, it lets me give it a new short name, but not a new title. however when i click the rename button it gives me this error:

 http://testing.plumi.org:16080/Plone/Members/reviewer/videos/folder_rename_form

We’re sorry, but there seems to be an error… The error has been logged as entry number 1296108720.650.681791824381.

If you need to report this to the Site Administration, please include this entry number in your message.

so.... i don't think this is what we wanted. we wanted that action removed when a video is in published or pending state.

comment:17 Changed 3 years ago by dave

Ok this appears to be a different specification altogether, the original issue was asking to remove the ability to rename when viewing the list of videos in folder contents view. (as referenced by  http://website.org/Members/USERNAME/videos/folder_contents in the ticket)

With the discussion above, the recommendation was to remove the contents tab, thus not giving users the view at all, because the listing of folder contents required users to be able to rename other items in it, Plone correctly warned the user after choosing a video unable to be renamed once it was attempted.

This appears to be another issue altogether with renaming the video object. When viewing the object there is no ability to rename in the drop down for reviewer when in Published state, so therefore the Reviewer should not have permissions to rename.

I just created a user ReviewerDave?, and cannot see a button to rename either at the object view, or via the folder view.

I tried this as manager, and it works however as an aside I also note the renaming does not make the ID more url friendly, resulting in :

 http://testing.plumi.org:16080/Plone/Members/reviewer/videos/test%20for%20222%20new

Not sure if this is expected behaviour in Plumi.

From the error log, this was the error logged in question.

Not sure where to go from here as I cannot reproduce the issue, maybe you were viewing an unrefreshed page of old content before the initial renaming?

Traceback (innermost last):
  Module ZPublisher.Publish, line 127, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 47, in call_object
  Module Products.CMFFormController.FSControllerPageTemplate, line 91, in __call__
  Module Products.CMFFormController.BaseControllerPageTemplate, line 28, in _call
  Module Products.CMFFormController.ControllerBase, line 231, in getNext
  Module Products.CMFFormController.Actions.TraverseTo, line 38, in __call__
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 47, in call_object
  Module Products.CMFFormController.FSControllerPythonScript, line 105, in __call__
  Module Products.CMFFormController.Script, line 145, in __call__
  Module Products.CMFCore.FSPythonScript, line 130, in __call__
  Module Shared.DC.Scripts.Bindings, line 324, in __call__
  Module Shared.DC.Scripts.Bindings, line 361, in _bindAndExec
  Module Products.PythonScripts.PythonScript, line 344, in _exec
  Module script, line 34, in folder_rename
   - <FSControllerPythonScript at /Plone/folder_rename used for /Plone/Members/reviewer/videos>
   - Line 34
  Module <string>, line 3, in renameObjectsByPaths
  Module plone.protect.utils, line 43, in _curried
  Module <string>, line 3, in renameObjectsByPaths
  Module AccessControl.requestmethod, line 70, in _curried
  Module Products.CMFPlone.PloneTool, line 1289, in renameObjectsByPaths
IndexError: list index out of range

comment:18 Changed 3 years ago by anna

I think you're confusing this ticket with another one (very similar number, 225 not 222!):  https://plumi.org/ticket/225 (that ticket is about folder contents view)

This ticket is about the rename action.

As per my previous comment, I tested this here:  http://testing.plumi.org:16080/Plone/Members/reviewer/videos/test-for-222/

to rename this - you just click the actions drop-down and select rename.

i can rename the video, and it renames successfully in pending state, as a Reviewer. i can give it a new short name, and a new title

in published state, it lets me give it a new short name, but not a new title. however when i click the rename button it gives me this error:

 http://testing.plumi.org:16080/Plone/Members/reviewer/videos/folder_rename_form

We’re sorry, but there seems to be an error… The error has been logged as entry number 1296108720.650.681791824381.

SO i think what we need to do is give permissions to anyone with Reviewer, Editor or Manager role to rename something (both SHORT NAME and TITLE) when it is in published state OR if this can't be done, to take this option out for Reviewers, Editors and Managers (remove this action) when something is in published state.

gawd, quite confusing issue really - let me know if this makes sense.

it sort of seems like a loophole that Plone has not noticed or not addressed - or a problem with our custom workflow?

comment:19 Changed 3 years ago by dave

As a note, with my ReviewerDave? (reviewer role) I do not get the option in the drop-down to rename.

This looks to be something tied to the owner ..

comment:20 Changed 3 years ago by and

  • Milestone changed from 4.1 Beta 1 (New Features and Fixes) to 4.2 RC 1 & Update of EM Staging

comment:21 Changed 3 years ago by and

  • Milestone changed from 4.2 RC 1 & Update of EM Staging to 4.1 RC 1 & EM Staging Update

comment:22 Changed 3 years ago by and

  • Owner dave deleted
  • Status changed from reopened to new

AFAIK dave isn't doing this ticket anymore. Please put yrself back on the ticket dave if I am mistaken.

comment:23 Changed 3 years ago by dimo

  • Milestone changed from 4.1 RC 1 & EM Staging Update to 4.2 Beta (Features - Content Sharing Focus)

I removed in testing.plumi.org the "Copy or Move" permission from anyone other than Managers or Reviewers for pending, published and featured states. That seems to fix the problem but it may have unexpected side effects.

Since we're about to release 4.1, I think we should push the issue for 4.2 in order to have sufficient time to extensively test it at testing.plumi.org.

Last edited 3 years ago by dimo (previous) (diff)

comment:24 Changed 3 years ago by and

  • Milestone changed from 4.2 Beta (Features - Content Sharing Focus) to 4.5 Beta Refactoring
View

Add a comment

Modify Ticket

Action
as new
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.