Modify

Ticket #188 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

indytube: No section: 'mencoder'

Reported by: denis Owned by: andycat
Priority: major Milestone: 3.1
Component: Transcoding Severity:
Keywords: Cc:
Who will test this:

Description

I am testing plumi-0.2.1-final on debian lenny.

The transcodage fails, so i just try to launch indytube.py on command-line and have this error.

python indytube.py

Traceback (most recent call last):
  File "indytube.py", line 233, in <module>
    main()
  File "indytube.py", line 223, in main
    indytuber.parse_config(indyconf_path)
  File "indytube.py", line 26, in parse_config
    self.MENCODER_LOCATION=config.get('mencoder','MENCODER_LOCATION')
  File "/usr/lib/python2.5/ConfigParser.py", line 292, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'mencoder'

Attachments

Change History

comment:1 Changed 5 years ago by andycat

sounds like your indytube.conf isnt correct. can u paste your indytube.conf and the command line you are using to launch indytube.

comment:2 Changed 5 years ago by andycat

  • Milestone set to 0.3 - Plone 3

comment:3 Changed 5 years ago by denis

I have launched

python indytube.py

Here is my indytube.conf

[encoder]
BE_HOW_NICE=18
CONVERT_THESE=['.avi','.qt','.mov','.mpeg','.mp4','.mpg','.asf','.wmv','.3gp','.ogg']
DO_ENCODING=True
NUMBER_OF_PARALLEL_ENCODERS=1
ENCODER_LOCKFILE_BASE=/opt/indytube/plumidemo-encoder.lock
POLLTIME=60

[mencoder]
MENCODER_LOCATION=/usr/bin/mencoder
MENCODER_OPTIONS=-really-quiet -of lavf -oac mp3lame -lameopts abr:br=64 -ovc lavc -lavcopts vcodec=flv:keyint=25:vbitrate=260:mbd=2:mv0:trell:v4mv:cbp:last_pred=3 -vf harddup,expand=:::::4/3,scale=320:240  -srate 22050 -ofps 25 -mc 0/10

[ffmpeg2theora]
CORTADO_LOCATION=http://plumi.domainepublic.net/flowplayer/cortado-ov-strippe.jar
FFMPEG2THEORA_COMMAND=ffmpeg2theora

[flvtool2]
FLVTOOL_LOCATION=/usr/bin/flvtool2

[paths]

VIDEO_FILE_DIRECTORY=/opt/Plone-2.5.5/zeocluster/client1/var/files/Members
FLV_FILE_DIRECTORY=/var/www/plumi-flv-files/
INCLUDE_FILE_DIRECTORY=/opt/Plone-2.5.5/zeocluster/client1/var/files/Members
INCLUDE_FILE_SUFFIX=.flv.inc
INCLUDE_TEMPLATE=/opt/indytube/template.include

[urls]
FLOWPLAYER_LOCATION=http://flv.domainepublic.net/flowplayer/FlowPlayerClassic.swf
VIDEO_SERVER_URL=http://flv.domainepublic.net/
SPLASH_IMAGE_BASE=http://plumi.domainepublic.net/flowplayer/
SPLASH_IMAGE_FILE=indytube.jpg

[logging]
LOG_FILE=/opt/indytube/plumi-wetube.log
LOG_LEVEL=logging.INFO

comment:4 Changed 5 years ago by denis

I just reinstall debian etch and the problem is the same

comment:5 Changed 5 years ago by denis

Just reinstall plumi-0-2-final in place of 0.2.1 and it's working now.

comment:6 Changed 5 years ago by andycat

This should fix it, it will go into plumi-0.2.2

http://plumi.org/changeset/367/indytube

comment:7 Changed 5 years ago by andycat

  • Status changed from new to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.